Jump to content
Sign in to follow this  
Different

COD 4 Crash On Startup

Recommended Posts

Hi everyone,
Literally its been years since I've been on this forum, but I kinda sorta need some help.
Everytime I go to start my game, it comes up shortly after trying to run saying "iw3mp.exe has stopped working". 
What I have tried:
Verifying game cache
Reinstalling (About 5 times)
Tried using ccleaner
Used the stereo mix method
Compatibility mode
Run as administrator

Anyone have any ideas of what to try next?
Anything would be appreciated, thanks.

-Different

  • Like 1

Share this post


Link to post

Wanna give us some system info and also maybe... try the nocd.exe of cod4 and see if that fixes it... as weird as that sounds.

 

Share this post


Link to post

Plug headphones in.

Or install CoD4x.

If you've done both of those then RIP.

Share this post


Link to post
7 hours ago, MiKeY said:

Wanna give us some system info and also maybe... try the nocd.exe of cod4 and see if that fixes it... as weird as that sounds.

 

I'll give that a try I guess. 
Specs:
i5-6500
16 GB DDR4 2133mhz
GTX 1060 6GB
Gigabyte Z-170 Gaming - 5 Mobo

3 hours ago, Matt. said:

Plug headphones in.

Or install CoD4x.

If you've done both of those then RIP.

I've tried both :/ 
Thanks for the advice though.

I tried the nocd.exe & no luck. However, thank you so much.
I appreciate the help.

Share this post


Link to post

Try downloading a cracked version of CoD4, if that works then it's something with Steam, if not then I haven't got a clue but it would help define the situation

Share this post


Link to post

You could contact the devs.... hahahahahahahahaha... I'm dying. 

Share this post


Link to post

I know headphones were mentioned, but did you try plugging a microphone in? That's what did it for my old desktop years ago. (Headphones in the mic port should work the same)

Share this post


Link to post

Hey zombie, haven't talked to you in forever. I have tried that, unfortunately it didn't work. Same with downloading a cracked version. 
Contacting devs?
I'm just killing myself there.

Share this post


Link to post
  • Have you tried going to; installation folder -> miles -> rename mssmp3.asi to mssmp3.asi.bak?
  • Also if not try reinstalling your sound card drivers
  • Try disabling front panel jack detection if you have a realtek onboard sound card.
  • Install the cod4 patches
  • Update bios

Also does singleplayer work?

Share this post


Link to post

I bet you installed the newest Windows update (Windows 10) version.

Do a rollback to:

Version: 1703
Build of OS: 15063.877

When I updated to then newest version, some applications didn't work anymore (for me Discord wasn't usable anymore). And who knows what else doesn't work properly from that update or it's just me and I have a old laptop that the hardware in it cannot communicate properly with the newest update. 

Anyways just try to do a rollback and see what the result is.

Share this post


Link to post

Update:
It was MSI Afterburner that was causing it. 
Closed the task & launched perfectly fine.

Thank you everyone.

Share this post


Link to post

Glad to hear man! I'm hoping to see you around sometime.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×